Activity

Service outage

Started
Lasted 7min
MAJORaffected
Creditor WebappAPIDebtor Webapp

RESOLVED

lasted 7min

The issue has been resolved.

INVESTIGATING

7min earlier

We are currently experiencing an outage due to high load on our authentication infrastructure. Our engineering team is working on fixing the issue.