Service outage
Started
Lasted 9min
MAJORaffected
Creditor WebappAPIDebtor Webapp
RESOLVED
lasted 9min
The issue has been resolved.
INVESTIGATING
9min earlier
We are currently experiencing an outage due to high load on our authentication infrastructure. Our engineering team is working on fixing the issue.