Service outage
Started
Lasted 19min
MAJORaffected
Creditor WebappAPIDebtor Webapp
RESOLVED
lasted 19min
The issue has been resolved.
INVESTIGATING
19min earlier
We are investigating the issue.
The issue has been resolved.
We are investigating the issue.